Monthly Archives: Ocak 2014

Unzip: skipping need PK compat. v4.6 (can do v2.1)

Sometimes extracting a zip file using the unzip command may result in the “skipping:  need PK compat. v4.5″ error message.

# unzip
   skipping:  need PK compat. v4.6 (can do v2.1)

This is due to the file been compressed with the latest version of PKZIP which the unzip command cannot handle. The solution is to install p7zip package which can handle the files compressed using PKZIP.

Download the latest version of p7zip:

# wget

Extract the file

# tar -jxf p7zip_9.20.1_x86_linux_bin.tar.bz2

goto the extracted directory and run the installer

# ./

This will install the ’7za’ command on your server using which the zip file can be extracted

# 7za x
 Processing archive:
 Extracting  filename
 Everything is Ok

Arama Terimleri:


Posted by on 25 Ocak 2014 in Bilgisayar, Linux, Server

Leave a comment